import re
regex = re.compile(r"(html) *(\+=) *\"<{1}(i|I)(m|M)(g|G) *(s|S)(r|R)(c|C) *= *'{0,1}\" *\+ *(val.imageLink) *\+ *\" *'{0,1} *>\";")
test_str = ("html+= \"<img src='\"+val.imageLink+\"'>\";\n"
"html += \"<img src ='\"+val.imageLink+\"'>\";\n"
"html+= \"<img src='\"+val.imageLink+\"'>\";\n"
"html+= \"<img src='\"+val.imageLink +\" ' >\";\n"
"html+= \"<img src='\"+val.imageLink+\"'>\";\n"
"html+= \"<img src='\"+val.imageLink+\"'>\";\n"
"html+= \"<img src='\"+val.imageLink+\"'>\";\n"
"html+= \"<img src='\"+val.imageLink+\"'>\";\n"
"html+= \"<img src='\"+val.imageLink+\"'>\";\n"
"html+= \"<img src='\"+val.imageLink+\"'>\";\n\n\n"
"html+=\"<img src='>\"+val.imageLink+\"'>\";")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")