#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<key>[\w]+)\s*=\s*(?<value>.+)"
Local $sString = "name = value" & @CRLF & _
"john = skeet" & @CRLF & _
"regex = beautiful" & @CRLF & _
"keywithnumbers123 = "some test string here"" & @CRLF & _
"keywithnumbersandunderscore1_23 = "another example here"" & @CRLF & _
"keywithspacesafterit = "some spacy text here"" & @CRLF & _
"notavalidkey$%&$§ = "I will get ignored"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")