$re = '/(?<key>[\w]+)\s*=\s*(?<value>.+)/';
$str = 'name = value
john = skeet
regex = beautiful
keywithnumbers123 = "some test string here"
keywithnumbersandunderscore1_23 = "another example here"
keywithspacesafterit = "some spacy text here"
notavalidkey$%&$§ = "I will get ignored"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);