use strict;
my $str = 'name = value
john = skeet
regex = beautiful
keywithnumbers123 = "some test string here"
keywithnumbersandunderscore1_23 = "another example here"
keywithspacesafterit = "some spacy text here"
notavalidkey$%&$§ = "I will get ignored"
';
my $regex = qr/(?<key>[\w]+)\s*=\s*(?<value>.+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}