package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<key>[\w]+)\s*=\s*(?<value>.+)`)
var str = `name = value
john = skeet
regex = beautiful
keywithnumbers123 = "some test string here"
keywithnumbersandunderscore1_23 = "another example here"
keywithspacesafterit = "some spacy text here"
notavalidkey$%&$§ = "I will get ignored"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}