// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<key>[\w]+)\s*=\s*(?<value>.+)").unwrap();
let string = "name = value
john = skeet
regex = beautiful
keywithnumbers123 = \"some test string here\"
keywithnumbersandunderscore1_23 = \"another example here\"
keywithspacesafterit = \"some spacy text here\"
notavalidkey$%&$§ = \"I will get ignored\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}