re = /(?<key>[\w]+)\s*=\s*(?<value>.+)/
str = 'name = value
john = skeet
regex = beautiful
keywithnumbers123 = "some test string here"
keywithnumbersandunderscore1_23 = "another example here"
keywithspacesafterit = "some spacy text here"
notavalidkey$%&$§ = "I will get ignored"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end