import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<key>[\\w]+)\\s*=\\s*(?<value>.+)";
final String string = "name = value\n"
+ "john = skeet\n"
+ "regex = beautiful\n"
+ "keywithnumbers123 = \"some test string here\"\n"
+ "keywithnumbersandunderscore1_23 = \"another example here\"\n"
+ "keywithspacesafterit = \"some spacy text here\"\n"
+ "notavalidkey$%&$§ = \"I will get ignored\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}