# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!jeffery)@.+//gm;t' <<< "jeffery@envato.com
fred@envato.com
jeffer@gmail.com
"