#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!jeffery)@.+"
Local $sString = "jeffery@envato.com" & @CRLF & _
"fred@envato.com" & @CRLF & _
"jeffer@gmail.com" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)