use strict;
my $str = 'jeffery@envato.com
fred@envato.com
jeffer@gmail.com
';
my $regex = qr/(?<!jeffery)@.+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";