const regex = /(?<!jeffery)@.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!jeffery)@.+', 'gm')
const str = `jeffery@envato.com
fred@envato.com
jeffer@gmail.com
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);