re = /(?<!jeffery)@.+/m
str = 'jeffery@envato.com
fred@envato.com
jeffer@gmail.com
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result