using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!jeffery)@.+";
string substitution = @"";
string input = @"jeffery@envato.com
fred@envato.com
jeffer@gmail.com
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}