#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([a-zA-Z0-9_\-.%:\(\)~]+)"
Local $sString = "http://www.domain.com/sites/sitename.com/" & @CRLF & _
"http://domain.com/sites/sitename/" & @CRLF & _
"https://www.instagram.com/p/CFaxzamnNI" & @CRLF & _
"gs://myproject.appspot.com/soundtracks/track-title.mp3" & @CRLF & _
"gs://myproject.appspot.com/videos/video-title.mpg" & @CRLF & _
"soundtracks/track-title.mp3" & @CRLF & _
"videos/video-title.mpg" & @CRLF & _
"https://www.youtube.com/watch?v=zra2DCd0DnY" & @CRLF & _
"https://youtu.be/QtSXxtVkR24" & @CRLF & _
"https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:Accueil_principal" & @CRLF & _
"https://fr.wikipedia.org/wiki/V%C3%A9nus_(plan%C3%A8te)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")