use strict;
my $str = 'http://www.domain.com/sites/sitename.com/
http://domain.com/sites/sitename/
https://www.instagram.com/p/CFaxzamnNI
gs://myproject.appspot.com/soundtracks/track-title.mp3
gs://myproject.appspot.com/videos/video-title.mpg
soundtracks/track-title.mp3
videos/video-title.mpg
https://www.youtube.com/watch?v=zra2DCd0DnY
https://youtu.be/QtSXxtVkR24
https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:Accueil_principal
https://fr.wikipedia.org/wiki/V%C3%A9nus_(plan%C3%A8te)';
my $regex = qr/([a-zA-Z0-9_\-.%:\(\)~]+)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}