$re = '/([a-zA-Z0-9_\-.%:\(\)~]+)/i';
$str = 'http://www.domain.com/sites/sitename.com/
http://domain.com/sites/sitename/
https://www.instagram.com/p/CFaxzamnNI
gs://myproject.appspot.com/soundtracks/track-title.mp3
gs://myproject.appspot.com/videos/video-title.mpg
soundtracks/track-title.mp3
videos/video-title.mpg
https://www.youtube.com/watch?v=zra2DCd0DnY
https://youtu.be/QtSXxtVkR24
https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:Accueil_principal
https://fr.wikipedia.org/wiki/V%C3%A9nus_(plan%C3%A8te)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);