import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9_\\-.%:\\(\\)~]+)";
final String string = "http://www.domain.com/sites/sitename.com/\n"
+ "http://domain.com/sites/sitename/\n"
+ "https://www.instagram.com/p/CFaxzamnNI\n"
+ "gs://myproject.appspot.com/soundtracks/track-title.mp3\n"
+ "gs://myproject.appspot.com/videos/video-title.mpg\n"
+ "soundtracks/track-title.mp3\n"
+ "videos/video-title.mpg\n"
+ "https://www.youtube.com/watch?v=zra2DCd0DnY\n"
+ "https://youtu.be/QtSXxtVkR24\n"
+ "https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:Accueil_principal\n"
+ "https://fr.wikipedia.org/wiki/V%C3%A9nus_(plan%C3%A8te)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}