const regex = /([a-zA-Z0-9_\-.%:\(\)~]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9_\\-.%:\\(\\)~]+)', 'gi')
const str = `http://www.domain.com/sites/sitename.com/
http://domain.com/sites/sitename/
https://www.instagram.com/p/CFaxzamnNI
gs://myproject.appspot.com/soundtracks/track-title.mp3
gs://myproject.appspot.com/videos/video-title.mpg
soundtracks/track-title.mp3
videos/video-title.mpg
https://www.youtube.com/watch?v=zra2DCd0DnY
https://youtu.be/QtSXxtVkR24
https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:Accueil_principal
https://fr.wikipedia.org/wiki/V%C3%A9nus_(plan%C3%A8te)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}