package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([a-zA-Z0-9_\-.%:\(\)~]+)`)
var str = `http://www.domain.com/sites/sitename.com/
http://domain.com/sites/sitename/
https://www.instagram.com/p/CFaxzamnNI
gs://myproject.appspot.com/soundtracks/track-title.mp3
gs://myproject.appspot.com/videos/video-title.mpg
soundtracks/track-title.mp3
videos/video-title.mpg
https://www.youtube.com/watch?v=zra2DCd0DnY
https://youtu.be/QtSXxtVkR24
https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:Accueil_principal
https://fr.wikipedia.org/wiki/V%C3%A9nus_(plan%C3%A8te)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}