# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z0-9_\-.%:\(\)~]+)"
test_str = ("http://www.domain.com/sites/sitename.com/\n"
"http://domain.com/sites/sitename/\n"
"https://www.instagram.com/p/CFaxzamnNI\n"
"gs://myproject.appspot.com/soundtracks/track-title.mp3\n"
"gs://myproject.appspot.com/videos/video-title.mpg\n"
"soundtracks/track-title.mp3\n"
"videos/video-title.mpg\n"
"https://www.youtube.com/watch?v=zra2DCd0DnY\n"
"https://youtu.be/QtSXxtVkR24\n"
"https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:Accueil_principal\n"
"https://fr.wikipedia.org/wiki/V%C3%A9nus_(plan%C3%A8te)")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.