import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[ ]*(\\/)?(.*)?script([ ]+.*|[^\\w]*)>";
final String string = "<script>gdfgdfgfdg\n"
+ "</script>\n"
+ "<script>gdfgdfg\n"
+ "< script>gdfg\n"
+ "<SCRiPt >gfdgfdgdfg\n"
+ "<script> alert(); </script>dgfgdg\n"
+ "< scRipT type=\"text/javascript\">;</scriPt >\n"
+ "<script>\n"
+ "< ScrIpT nn >\n"
+ "<SCRiPT >\n"
+ "< script type=\"js\"> etc.\n"
+ "hi\n"
+ "<img>\n"
+ "<img script>\n"
+ "<scripting>\n"
+ "<s cr i pt>\n"
+ "<xxscriptxx>\n"
+ "< scRipT type=\"text/javascript\">;</ scriPt >";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}