// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<[ ]*(\/)?(.*)?script([ ]+.*|[^\w]*)>").unwrap();
let string = "<script>gdfgdfgfdg
</script>
<script>gdfgdfg
< script>gdfg
<SCRiPt >gfdgfdgdfg
<script> alert(); </script>dgfgdg
< scRipT type=\"text/javascript\">;</scriPt >
<script>
< ScrIpT nn >
<SCRiPT >
< script type=\"js\"> etc.
hi
<img>
<img script>
<scripting>
<s cr i pt>
<xxscriptxx>
< scRipT type=\"text/javascript\">;</ scriPt >";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}