$re = '/<[ ]*(\/)?(.*)?script([ ]+.*|[^\w]*)>/i';
$str = '<script>gdfgdfgfdg
</script>
<script>gdfgdfg
< script>gdfg
<SCRiPt >gfdgfdgdfg
<script> alert(); </script>dgfgdg
< scRipT type="text/javascript">;</scriPt >
<script>
< ScrIpT nn >
<SCRiPT >
< script type="js"> etc.
hi
<img>
<img script>
<scripting>
<s cr i pt>
<xxscriptxx>
< scRipT type="text/javascript">;</ scriPt >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);