import re
regex = re.compile(r"<[ ]*(\/)?(.*)?script([ ]+.*|[^\w]*)>", flags=re.IGNORECASE)
test_str = ("<script>gdfgdfgfdg\n"
"</script>\n"
"<script>gdfgdfg\n"
"< script>gdfg\n"
"<SCRiPt >gfdgfdgdfg\n"
"<script> alert(); </script>dgfgdg\n"
"< scRipT type=\"text/javascript\">;</scriPt >\n"
"<script>\n"
"< ScrIpT nn >\n"
"<SCRiPT >\n"
"< script type=\"js\"> etc.\n"
"hi\n"
"<img>\n"
"<img script>\n"
"<scripting>\n"
"<s cr i pt>\n"
"<xxscriptxx>\n"
"< scRipT type=\"text/javascript\">;</ scriPt >")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")