const regex = /<[ ]*(\/)?(.*)?script([ ]+.*|[^\w]*)>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[ ]*(\\\/)?(.*)?script([ ]+.*|[^\\w]*)>', 'gi')
const str = `<script>gdfgdfgfdg
</script>
<script>gdfgdfg
< script>gdfg
<SCRiPt >gfdgfdgdfg
<script> alert(); </script>dgfgdg
< scRipT type="text/javascript">;</scriPt >
<script>
< ScrIpT nn >
<SCRiPT >
< script type="js"> etc.
hi
<img>
<img script>
<scripting>
<s cr i pt>
<xxscriptxx>
< scRipT type="text/javascript">;</ scriPt >`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}