# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)(?:\[|\()(?:M|F|T|MF|FM|\?)(?:\d+)?(?:M|F|T|MF|FM|\?)?(?:\d+)?(?:\]|\))//gm;t' <<< "[F]
(F)
[M]
(M)
[T]
(T)
[FM]
[MF]
(FM)
(MF)
[F44]
(f45)
[F44M50]
[M21F31]
(F44M50)
(M21F31)"