// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(?:\[|\()(?:M|F|T|MF|FM|\?)(?:\d+)?(?:M|F|T|MF|FM|\?)?(?:\d+)?(?:\]|\))").unwrap();
let string = "[F]
(F)
[M]
(M)
[T]
(T)
[FM]
[MF]
(FM)
(MF)
[F44]
(f45)
[F44M50]
[M21F31]
(F44M50)
(M21F31)";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}