using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:\[|\()(?:M|F|T|MF|FM|\?)(?:\d+)?(?:M|F|T|MF|FM|\?)?(?:\d+)?(?:\]|\))";
string substitution = @"";
string input = @"[F]
(F)
[M]
(M)
[T]
(T)
[FM]
[MF]
(FM)
(MF)
[F44]
(f45)
[F44M50]
[M21F31]
(F44M50)
(M21F31)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}