$re = '/(?i)(?:\[|\()(?:M|F|T|MF|FM|\?)(?:\d+)?(?:M|F|T|MF|FM|\?)?(?:\d+)?(?:\]|\))/m';
$str = '[F]
(F)
[M]
(M)
[T]
(T)
[FM]
[MF]
(FM)
(MF)
[F44]
(f45)
[F44M50]
[M21F31]
(F44M50)
(M21F31)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;