use strict;
my $str = '[F]
(F)
[M]
(M)
[T]
(T)
[FM]
[MF]
(FM)
(MF)
[F44]
(f45)
[F44M50]
[M21F31]
(F44M50)
(M21F31)';
my $regex = qr/(?i)(?:\[|\()(?:M|F|T|MF|FM|\?)(?:\d+)?(?:M|F|T|MF|FM|\?)?(?:\d+)?(?:\]|\))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";