const regex = new RegExp('(?i)(?:\\[|\\()(?:M|F|T|MF|FM|\\?)(?:\\d+)?(?:M|F|T|MF|FM|\\?)?(?:\\d+)?(?:\\]|\\))', 'gm')
const str = `[F]
(F)
[M]
(M)
[T]
(T)
[FM]
[MF]
(FM)
(MF)
[F44]
(f45)
[F44M50]
[M21F31]
(F44M50)
(M21F31)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);