package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\s?(?:RuleSet|Data):\[[^]]*](?:,?\s|$)`)
var str = `RuleSet:[text], Data:[{text}{text}...] RuleSet:[text], Data:[{text},{text},....] SomeText RuleSet:[{text}...], Data:[{text}...]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}