const regex = /\s?(?:RuleSet|Data):\[[^]]*](?:,?\s|$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s?(?:RuleSet|Data):\\[[^]]*](?:,?\\s|$)', 'gmi')
const str = `RuleSet:[text], Data:[{text}{text}...] RuleSet:[text], Data:[{text},{text},....] SomeText RuleSet:[{text}...], Data:[{text}...]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);