re = /\s?(?:RuleSet|Data):\[[^]]*](?:,?\s|$)/mix
str = 'RuleSet:[text], Data:[{text}{text}...] RuleSet:[text], Data:[{text},{text},....] SomeText RuleSet:[{text}...], Data:[{text}...]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result