import re
regex = re.compile(r"""
\s?(?:RuleSet|Data):\[[^]]*](?:,?\s|$)
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = "RuleSet:[text], Data:[{text}{text}...] RuleSet:[text], Data:[{text},{text},....] SomeText RuleSet:[{text}...], Data:[{text}...]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)