$re = '/\s?(?:RuleSet|Data):\[[^]]*](?:,?\s|$)/mix';
$str = 'RuleSet:[text], Data:[{text}{text}...] RuleSet:[text], Data:[{text},{text},....] SomeText RuleSet:[{text}...], Data:[{text}...]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;