use strict;
my $str = 'RuleSet:[text], Data:[{text}{text}...] RuleSet:[text], Data:[{text},{text},....] SomeText RuleSet:[{text}...], Data:[{text}...]';
my $regex = qr/\s?(?:RuleSet|Data):\[[^]]*](?:,?\s|$)/mixp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";