const regex = /"(.*?)\(.*?:(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(.*?)\\(.*?:(.*)', '')
const str = `"text1(text1)":http://www.example.com/mypage`;
const subst = `<a href="\2">\1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);