$re = '/"(.*?)\(.*?:(.*)/';
$str = '"text1(text1)":http://www.example.com/mypage';
$subst = "<a href=\"\2\">\1</a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;