re = /"(.*?)\(.*?:(.*)/
str = '"text1(text1)":http://www.example.com/mypage'
subst = '<a href="\\2">\\1</a>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result