import re
regex = re.compile(r"\"(.*?)\(.*?:(.*)")
test_str = "\"text1(text1)\":http://www.example.com/mypage"
subst = "<a href=\"\\2\">\\1</a>"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)