#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[-+]?(\d+((\,(\d{2,}))*\,(\d{3}))*)?(\.\d*)?"
Local $sString = "+1111,22,333.44444" & @CRLF & _
"" & @CRLF & _
"[-+]?" & @CRLF & _
"(" & @CRLF & _
"\d+" & @CRLF & _
"(" & @CRLF & _
"(" & @CRLF & _
"\," & @CRLF & _
"(" & @CRLF & _
"\d{2,}" & @CRLF & _
")" & @CRLF & _
")*" & @CRLF & _
"\," & @CRLF & _
"(\d{3})" & @CRLF & _
")*" & @CRLF & _
")?" & @CRLF & _
"(\.\d*)?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")