using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-+]?(\d+((\,(\d{2,}))*\,(\d{3}))*)?(\.\d*)?";
string input = @"+1111,22,333.44444
[-+]?
(
\d+
(
(
\,
(
\d{2,}
)
)*
\,
(\d{3})
)*
)?
(\.\d*)?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}