// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[-+]?(\d+((\,(\d{2,}))*\,(\d{3}))*)?(\.\d*)?").unwrap();
let string = "+1111,22,333.44444
[-+]?
(
\\d+
(
(
\\,
(
\\d{2,}
)
)*
\\,
(\\d{3})
)*
)?
(\\.\\d*)?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}