import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[-+]?(\\d+((\\,(\\d{2,}))*\\,(\\d{3}))*)?(\\.\\d*)?";
final String string = "+1111,22,333.44444\n\n"
+ "[-+]?\n"
+ "(\n"
+ "\\d+\n"
+ "(\n"
+ "(\n"
+ "\\,\n"
+ "(\n"
+ "\\d{2,}\n"
+ ")\n"
+ ")*\n"
+ "\\,\n"
+ "(\\d{3})\n"
+ ")*\n"
+ ")?\n"
+ "(\\.\\d*)?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}