re = /[-+]?(\d+((\,(\d{2,}))*\,(\d{3}))*)?(\.\d*)?/
str = '+1111,22,333.44444
[-+]?
(
\\d+
(
(
\\,
(
\\d{2,}
)
)*
\\,
(\\d{3})
)*
)?
(\\.\\d*)?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end