package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-+]?(\d+((\,(\d{2,}))*\,(\d{3}))*)?(\.\d*)?`)
var str = `+1111,22,333.44444
[-+]?
(
\d+
(
(
\,
(
\d{2,}
)
)*
\,
(\d{3})
)*
)?
(\.\d*)?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}