$re = '/[-+]?(\d+((\,(\d{2,}))*\,(\d{3}))*)?(\.\d*)?/';
$str = '+1111,22,333.44444
[-+]?
(
\\d+
(
(
\\,
(
\\d{2,}
)
)*
\\,
(\\d{3})
)*
)?
(\\.\\d*)?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);