#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[a-zA-Z0-9'\.,\s\-&()]{2,20}$"
Local $sString = "1234AqwdaDS1234567.5"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)